Evgenij LegotskojSept. 5, 2015, 12:43 p.m.

DELL Networking. Basics Routing Policy (Part 3)

VLAN Traffic Redirection

Passing traffic without PBR

Example. Comparison of packets from one VLAN, then routing the output of another VLAN to their destination.

Remote server X, Y, Z hourly cached on the local server A, B, C. Members VLAN 10 use locally cached server 99% of the time, but occasionally need access to current data from the server X, Y, Z, which are located in another city . Traffic on the road between the local and remote servers are often higher than 100% of the bandwidth. To minimize delays in traffic between VLAN 10 user stations and remote servers are configured PBR to avoid bottlenecks.

Traffic Passage in the presence of PBR

If configured routing rules, the traffic flow will be different from the original version, where the traffic comes at the lower path, but does not mean that at best.

In this case, the traffic goes through VLAN 20, which has a high-speed connection to the remote server.

Configuration

Initial data

When setting up, the following input data.

VLAN 10, 20
Subnets: 1.1.1.0, 2.2.2.0, 3.3.3.0
IP-adresses: 1.1.1.50, 1.1.1.51, 1.1.1.52, 3.3.3.3, 3.3.3.4, 3.3.3.5, 2.2.2.1, 2.2.2.2

The first step is performed to create access lists for ABC and XYZ servers servers.

/* Creating ACLs with IP-addresses of sources - Server ABC */
console(config)#ip access-list servers-ABC 
console(config-ip-acl)#permit ip host 1.1.1.50 any 
console(config-ip-acl)#permit ip host 1.1.1.51 any 
console(config-ip-acl)#permit ip host 1.1.1.52 any 
console(config-ip-acl)#exit 

Create Access-list with destination IP addresses of servers XYZ… 
console(config)#ip access-list allow-1-1-1-clients 
console(config-ip-acl)#permit ip any host 3.3.3.3 
console(config-ip-acl)#permit ip any host 3.3.3.4 
console(config-ip-acl)#permit ip any host 3.3.3.5 
console(config-ip-acl)#exit

Creating a Route-Map, using access lists to servers from the routing policies to reroute customers through VLAN 20.

console(config)#route-map clients-to-XYZ deny 10 
console(route-map)#match ip address servers-ABC
console(route-map)#exit 
console(config)#route-map clients-to-XYZ permit 20 
console(route-map)#match ip address allow-1-1-1-clients 
console(route-map)#set ip next-hop 2.2.2.2 
console(route-map)#exit 

Assign Route-Map and IP-addresses for the VLAN 10

console(config)#vlan 10 
console(config-vlan10)#exit 
console(config)#interface vlan 10 
console(config-if-vlan10)#ip address 1.1.1.1 255.255.255.0 
console(config-if-vlan10)#ip policy route-map clients-to-XYZ 
console(config-if-vlan10)#exit

Then we put this remaining set of commands to configure routing

console(config)#ip routing 
console(config)#vlan 20 
console(config-vlan20)#exit 
console(config)#interface vlan 20 
console(config-if-vlan20)#ip address 2.2.2.1 255.255.255.0 
console(config-if-vlan20)#exit 
console(config)#interface range gi1/0/1-10 
console(config-if)#switchport access vlan 10 
console(config)#interface range gi1/0/11-20 
console(config-if)#switchport access vlan 20
We recommend hosting TIMEWEB
We recommend hosting TIMEWEB
Stable hosting, on which the social network EVILEG is located. For projects on Django we recommend VDS hosting.
Support the author Donate

Comments

Only authorized users can post comments.
Please, Log in or Sign up
How to become an author?

Contribute to the evolution of the EVILEG community.

Learn how to become a site author.

Learn it
Donate

Good day, Dear Users!!!

I am Evgenii Legotckoi, developer of EVILEG. And it is my hobby project, which helps to learn programming another programmers and developers

If the site helped you, and you want also support the development of the site, than you can donate by following ways

PayPalYandex.Money
Timeweb

Let me recommend you the excellent hosting on which EVILEG is located.

For many years, Timeweb has been proving his stability.

For projects on Django I recommend VDS hosting

View Hosting
KA

C++ - Тест 003. Условия и циклы

  • Result:78points,
  • Rating points2
R

C++ - Test 002. Constants

  • Result:75points,
  • Rating points2
R

C++ - Test 001. The first program and data types

  • Result:73points,
  • Rating points1
Last comments
V

Django - Tutorial 027. Implementation Google reCAPTCHA

Спасибо. Только использую декоратор не в urls.py а перед views
R

Qt WinAPI - Lesson 001. How to collect all DLL, which used in Qt project?

Вы меня не совсем правильно поняли, но все равно спасибо, принял все к сведению. Все сделал как вы сказали, все отлично работает, еще раз огромнейшее спасибо) Разве что только что были опять про…

Qt WinAPI - Lesson 001. How to collect all DLL, which used in Qt project?

Стоило перед использованием что ли инструкцию прочитать https://www.cyberforum.ru/blogs/131347/blog2457.html "После сборки при запуске требовались dll," Ясное дело стоило задепло…
R
R

Qt WinAPI - Lesson 001. How to collect all DLL, which used in Qt project?

Да, собралось. После сборки при запуске требовались dll, перекинул всю папки bin, plugins(не знаю как можно было сделать более умно). Как я понял в первой строке путь к екзешнику вставляю, втор…
Now discuss on the forum
_

Не работают слоты/сигналы

Помогите разобраться. MainWindow::on_push_autorisation_clicked() - при нажатии на кнопку отправляется сигнал. В слоте выводим текст и отправляем сигнал дальше. Если не отправлять сигна…

Как в Qt в qmenu добавить scrollarea

Вот это наследованный класс меню. Но посути это обычное меню. #pragma once#include <QtWidgets>class TransMenu : public QMenu { Q_OBJECTpublic: TransMenu(QWidget* parent = …

Qt C++ и Python

Красиво/некрасиво - это скорее моё личное отношение. Если есть возможность ограничить количество интсрументов, то лучше ограничить. Но не зацикливайтесь на этом. Если у вас есть скрипты Py…

Qt + OpenGL glDeleteVertexArrays

Я не уверен, поскольку с OpenGL очень мало работал. Но может быть OpenGL контекст виджета нужно переинициализовывать. И ещё виджет стоит удалять через метод deleteLater() а не п…

QWebEngineView не запускается если к ПК подключено несколько мониторов

Ну я имел ввиду посмотреть на другом ПК с другой графикой и парой мониторов. Как моей программе назначить использовать определенный граф. адаптер? Вот тут понятия не имею.
About
Services
© EVILEG 2015-2020
Recommend hosting TIMEWEB